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Proudly provided by:
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Warning: Magento 1.x support has been dropped. Consider migration to OpenMage.
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CHAPTER

ONE

OVERVIEW

This extension provides an official integration of your OpenMage store with Amazon Pay service. They help your
customers shop quickly, safely and securely. Your customers can pay on your website without re-entering their payment
and address details. All Amazon transactions are protected by Amazon’s A-to-z Guarantee.

The extension is a pure payment solution. No item level is communicated to Amazon Payments and it allows you to
manage your orders directly from OpenMage.

1.1 About Amazon Pay

Amazon Pay is an end-to-end payment solution that gives hundreds of millions of active Amazon customers a familiar,
fast, and secure way to complete their purchase through your online store. Shoppers can use the address and payment
information already stored in their Amazon account to check out - avoiding account creation or the need to re-enter
their billing and shipping information. The performance is continually optimised by technology, learnings, and best
practises from Amazon.

1.1.1 Key Benefits

• Reduce friction with a payment process that customers trust and can complete in minimal clicks

• Proactively notify customers when their order is on its way or has arrived with Amazon Alexa

• Rest assured with advanced fraud protection technology backed by Amazon

• Easily integrate Amazon Pay into your online store

1.1.2 Key Features

• PSD2 compliant: Built-in support for strong customer authentication as required under PSD2

• Delivery Notifications: Proactively alert customers on the arrival status of physical goods orders via Amazon
Alexa

• Multi-currency: Maintain the local currency experience across the shopping journey and help customers avoid
currency conversion fees from their credit card issuer or bank

• Amazon Sign-in: Reduce friction during account creation and sign-in by offering a fast and secure way for
customers to authenticate through Amazon. Shoppers with an active Amazon account don’t need to login again

• Automatic Decline Handling: Reduce lost sales with a consistent experience for customers to gracefully recover
from a declined payment

3
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• Payment Protection Policy: Protection against fraud-related chargebacks (check User Agreement for more de-
tails)

• Amazon Pay A-to-z Guarantee: Increase customer confidence to complete purchase in your online store with
extra assurance on the timeliness of delivery and order quality

1.2 Getting the extension

You can install the extension either via Connect Manager or manually, downloading the installation package from
Creativestyle connect channel.

Refer to the Installation section to get more details concerning installation procedure.

1.3 Extension features

• Amazon Pay button in the shopping cart, in the 1st step of one page checkout and on the product page

• Amazon Sign-in button on the customer login and registration page

• Support for payment authorizations, captures and refunds (also partial refunds)

• Supports Amazon Instant Payment Notifications

• Live & sandbox modes available

• JSON-based event logger

• Multilanguage, available languages: en, de, fr, es, it

• Multicurrency

1.4 Extension vendor

This extension has been developed by creativestyle GmbH in cooperation with Amazon Payments Europe S.C.A.

Creativestyle is an award-winning, pioneering e-commerce agency with more than 15 years of experience. Since 2001,
they have been developing expertise in the field of technology and software solutions. With an 80 person team of
experts consisting of certified specialists in the fields of design, development and management of innovative projects,
they can guarantee a full range of services from consulting and planning, through concept and design, to technical
implementation and subsequent project support.

creativestyle GmbH
Erika-Mann-Straße 53
80636 München
Germany
http://www.creativestyle.de
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CHAPTER

TWO

PREREQUISITES

2.1 System requirements

Amazon Pay extension for OpenMage requires you to have a valid Amazon Payments account and a webserver running
an OpenMage store instance with the following conditions met:

• OpenMage 19.4.4 or higher

• cURL for PHP

• DOM / XML for PHP

• valid SSL certificate

Important: This extension works with OpenMage 19.4.4 or higher. Please refer to Installing the extension on Magento
lower than 1.9.4.0 to find out how to install it on the legacy versions of Magento.
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CHAPTER

THREE

INSTALLATION

3.1 Pre-installation steps

• Create a backup of your shop before proceeding to install.

• If your shop is using compilation (you can check it in System → Tools → Compilation), disable it please before
proceeding to install.

3.2 Installation process

3.2.1 Installation via Connect Manager

• Go to System → Magento Connect → Magento Connect Manager and enter your admin credentials to get logged
in.

7
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• In the Install New Extensions section paste the following extension key:

http://connect.creativestyle.de/Creativestyle_AmazonCheckout

and click Install button. Connect Manager will validate the key and check the extension dependencies and will display
a pre-installation summary. Click Proceed button to start the installation.

• After the successful installation, please click on Refresh button to refresh the list of the installed extensions and
make sure that Amazon Pay is present on that list.

• Proceed to the Post-installation steps.

8 Chapter 3. Installation
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3.2.2 Manual installation

• Go to Creativestyle OpenMage connect channel and download the recent installation package of the extension.
Unpack the downloaded file to your OpenMage root directory.

Tip: If you are using any VCS (git, svn, mercurial) for versioning your shop basecode, you can also commit the content
of the downloaded file to the VCS repository and deploy it to your shop.

• Proceed to the Post-installation steps.

3.3 Post-installation steps

• If you’re using custom design theme, refer to the Templates customization section to find out how to adjust
Amazon Pay templates to your needs.

• Go to System → Cache Management and flush OpenMage cache storage.

• If you have disabled compiler in pre-installation stage, you can go now to System → Tools → Compilation,
recompile and enable compiler again.

• Logout from the OpenMage admin and login again.

Voila! The Amazon Pay extension shall be installed now. You can proceed to the Configuration followed by Frontend
templates customization (if applicable).

3.4 Upgrade

3.4.1 Pre-upgrade steps

1. Create a backup of your shop before proceeding to upgrade.

2. If your shop utilises compilation (you can check it in System → Tools → Compilation), disable it please before
proceeding to upgrade.

3.4.2 Upgrade process

• Go to System → Magento Connect → Magento Connect Manager and enter your admin credentials to get logged
in.

3.3. Post-installation steps 9
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• Click Check for Upgrades button in the Manage Existing Extensions section. If the newest version of Amazon Pay
is available, the Creativestyle_AmazonCheckout extension on the list will be highlighted with the yellow color. In
the corresponding action dropdown list please select Upgrade to X.X.X (stable) option and click Commit changes
button.

• After the successful upgrade, please click on Refresh button to refresh the list of the installed extensions and
assure that Amazon Chekout v2 (identified as Creativestyle_AmazonCheckout) was upgraded to the desired
version.

• Proceed to the Post-upgrade steps section.

10 Chapter 3. Installation
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3.4.3 Post-upgrade steps

• Go to System → Cache Management and flush Magento cache storage.

• If you have disabled compiler in pre-installation stage, you can go now to System → Tools → Compilation,
recompile and enable compiler again.

3.4. Upgrade 11
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CHAPTER

FOUR

CONFIGURATION

After the successful installation you can proceed to the configuration. In OpenMage admin go to creativestyle →
Amazon Pay and Login with Amazon → Settings (or System → Configuration → Amazon Payments tab).

13
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Available options are grouped into two main sections: Account credentials and Configuration (with Expert Mode
subsection).

4.1 Account credentials

In this section you can define your Amazon Payments seller account credentials.

4.1.1 Payment Region, Merchant ID and Client ID

Fill out those fields with your Amazon Payments seller credentials. You can find them in the Amazon Seller Central.

4.1.2 Private Key and Public Key ID

Fill out those fields with the Private Key generated in Amazon Seller Central and the corresponding Public Key ID.

4.2 Advanced configuration

4.2.1 Operation mode

Sandbox mode has been designed to test the Amazon Pay service. In sandbox mode the selected payment method is
not charged. In general, sandbox mode should be enabled for development and staging environments for testing and
always has to be disabled for production environments. Never show the sandbox buttons and widgets to buyers in your
live environment.

4.2.2 Payment Action

You can select the desired payment action taken after an order is placed. Available options are:

• Authorize (default) - order reference creation is followed by automatic authorization request. Capture must be
requested manually by creating an invoice with Capture online option selected.

• Authorize & capture - order reference creation is followed by automatic authorization and capture request.

4.3 Expert Mode

Please click on the Expert Mode link to reveal the most advanced configuration options.

4.1. Account credentials 15
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4.3.1 Display language

In this option you can select a language which will be used for displaying all elements (forms, widgets) generated by
Amazon Pay. Selected language will be also used to localize emails sent by Amazon Payments to the customer after
purchase.

Amazon Sign-in

4.3.2 Enable

By switching this option you can enable or disable Amazon Sign-in feature. Amazon Sign-in allows users to login to
your shop using their Amazon username and password. The name, email address and user id is fetched from Amazon
in order to facilitate the creation of an OpenMage account. Shipping and billing address will be retrieved as part of the
checkout.

4.3.3 Button color

In this option you can select the desired color of Amazon Sign-in button. The following predefined colors ara available:

• Gold

• Light gray

• Dark gray

Amazon Pay

4.3.4 Enable

By switching this option you can enable or disable Amazon Pay. This option must be set to Yes if you want to provide
payment service to your customers.

4.3.5 Display on Product Details Page

By switching this option you can enable or disable Amazon Pay button on the product details page. Amazon Pay button
on the product details page allows the buyer to add the product to the cart and init the checkout with just one click.

4.3.6 Button color

In this option you can select the desired color of Amazon Pay button. The following predefined colors ara available:

• Gold

• Light gray

• Dark gray

16 Chapter 4. Configuration



Amazon Pay - extension for OpenMage, Release 10.1.3

Delivery restrictions

4.3.7 Restrict packstation addresses

By enabling this option you will restrict delivery to the addresses identified as packstations.

4.3.8 Restrict PO box addresses

By enabling this option you will restrict delivery to the addresses identified as PO Boxes.

Communication

4.3.9 Store name

The value set for this option will appear as your store name on all email send by Amazon Pay.

4.3.10 Display name on bank account statement

Use this option to set the name of your store shown on the bank account statements. The maximum length of the value
for this option is 16 chars.

Alexa Delivery Notifications

4.3.11 Enable Delivery Notifications

Alexa delivery notifications for Amazon Pay merchants allow you to pro-actively inform your customers if their order
is on its way or has arrived.

4.3.12 Carrier codes

This option allows to map carriers from your shop to the Amazon Pay predefined carriers. Please use the Carrier codes
form by selecting your available carriers and assign them to the matching one in the Amazon Pay carrier list.

Developer options

4.3.13 Enable logging

The Pay with Amazon extension comes with a dedicated logging mechanism. If this option is enabled all exceptions
and API calls will be saved to the appropriate log file in var/log/amazonpayments/v2 directory in your OpenMage
installation.

4.3. Expert Mode 17
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4.3.14 Allowed IPs (comma separated)

For testing or debugging purposes you can restrict access to Amazon Pay checkout in your shop to certain IP numbers
only. Amazon Pay button will be shown only for the visitors coming from allowed IPs. You can set more than one
allowed IP separated with commas.
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CHAPTER

FIVE

CUSTOMIZATION

5.1 Frontend templates

If you are using a custom design theme and would like to adjust the appearance of Amazon Pay templates, please
complete the following steps (all paths are relative to the OpenMage root folder):

Warning: Never edit the default template or skin files directly as they can be (and surely will be) overwritten when
upgrading this extension to a newer version. Edit their copies only as described below.

• Create folders:

app/design/frontend/YOURPACKAGE/YOURTHEME/template/creativestyle/amazonpayments skin/
frontend/YOURPACKAGE/YOURTHEME/creativestyle/css skin/frontend/YOURPACKAGE/YOURTHEME/
creativestyle/images

On Unix-like (Linux, BSD) servers you can achieve this by running following commands, please remember to
replace YOURPACKAGE and YOURTHEME with the real names of your theme:

$ cd /path/to/your/OpenMage
$ mkdir -p app/design/frontend/YOURPACKAGE/YOURTHEME/template/creativestyle/
→˓amazonpayments
$ mkdir -p skin/frontend/YOURPACKAGE/YOURTHEME/creativestyle/css
$ mkdir -p skin/frontend/YOURPACKAGE/YOURTHEME/creativestyle/images

• Clone the following files:

app/design/frontend/base/default/layout/amazonpayments.xml app/design/frontend/
base/default/template/creativestyle/amazonpayments/* skin/frontend/base/default/
creativestyle/css/amazonpayments.css skin/frontend/base/default/creativestyle/images/
*

On Unix-like (Linux, BSD) servers you can achieve this by running following commands, please remember to
replace YOURPACKAGE and YOURTHEME with the real names of your theme:

$ cd /path/to/your/OpenMage
$ cp app/design/frontend/base/default/layout/amazonpayments.xml app/design/
→˓frontend/YOURPACKAGE/YOURTHEME/layout/amazonpayments.xml
$ cp app/design/frontend/base/default/template/creativestyle/amazonpayments/
→˓* app/design/frontend/YOURPACKAGE/YOURTHEME/template/creativestyle/
→˓amazonpayments/*
$ cp skin/frontend/base/default/creativestyle/css/amazonpayments.css skin/
→˓frontend/YOURPACKAGE/YOURTHEME/creativestyle/css/amazonpayments.css

(continues on next page)
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(continued from previous page)

$ cp skin/frontend/base/default/creativestyle/images/* skin/frontend/
→˓YOURPACKAGE/YOURTHEME/creativestyle/images/*

After cloning the above files to your theme folders, you can adjust the design by editing the appropriate files (HTML
templates, CSS stylesheets and layout file). You can enable Template Path Hints to find out the names of the template
files used by the extension in particular steps of the checkout process (in OpenMage admin, within selected store view
scope: System → Configuration → Developer → Debug).

Note: Please note that the ID attributes of all HTML tags must be preserved, otherwise changes to the corresponding
JS scripts must be applied (do not try to change it unless you know what are you doing).

Basic appearance of rendered Amazon Pay widgets (button color and size of all widgets) can be set in the Amazon Pay
extension settings (System → Configuration → Amazon Payments), see configuration-common-appearance-settings,
configuration-login-appearance-settings and configuration-pay-appearance-settings for more details.

5.2 Amazon Pay logo

If you want to place the Amazon Pay logo in your shop to let your customers know you’re using payment services
provided by Amazon Pay, you can find a download link of marketing tools here: * UK: https://payments.amazon.co.
uk/merchant/tools * DE: https://payments.amazon.de/merchant/tools

To complement the logos you should mention Amazon Pay under your listing of supported payment methods.

20 Chapter 5. Customization
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CHAPTER

SIX

AMAZON SIGN-IN

Amazon Sign-in allows users to login to your shop using their Amazon user name and password. All available data
needed for creating an account or placing an order in your OpenMage shop (including name, email address, and zip
code) are fetched automatically from customer’s Amazon account.

6.1 Requirements

Amazon Sign-in service requires you to have a valid Amazon Payments account and OpenMage store with a valid
SSL certificate installed and properly configured in your shop. By “installed and properly configured SSL certificate”
it is meant that your webserver is configured to serve pages via HTTPS protocol, Base URL config option is set to the
HTTPS-based URL and in Web → Secure section of OpenMage settings.

6.2 Amazon Sign-in button

The Amazon Sign-in button appears in several places in the shop:

• on the customer login page,

• on the customer registration page.

21
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You can also place the Amazon Sign-in button in any place you like by including following statement in the template
file:

<div data-lpa-role="login-button"></div>

Pressing the Amazon Sign-in button launches the Amazon authentication window, where the customer is asked for his
Amazon account e-mail address and password.

22 Chapter 6. Amazon Sign-in
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After a successful login the customer is redirected to the user area in your shop.

Note: When the customer uses the Amazon Sign-in for the first time in your shop and account with the same e-mail
address already exists in your shop, he will be asked to enter his shop password to match both shop and Amazon
accounts. Moreover, if you require additional data from your customers which cannot be provided by Amazon (like
date of birth or gender), the customer will be asked for those data in a dedicated form, that appears after the first use of
Amazon Sign-in button.

6.2. Amazon Sign-in button 23
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CHAPTER

SEVEN

ORDER & PAYMENT WORKFLOW

The Amazon Pay extension follows the standard OpenMage order and payment workflow, and thus processing Amazon
Pay payments doesn’t differ significantly from other payment methods available in OpenMage, making it easy to handle.
The most important difference, comparing to the standard OpenMage orders, is delayed access to the billing address,
which is backfilled later in the synchronization process after the successful authorization.

All Amazon Pay objects (ChargePermission, Charge and Refund) are reflected in corresponding payment transactions in
OpenMage, which are connected with appropriate document entities provided by the OpenMage, (invoices for captures,
credit memos for refunds).

7.1 Amazon Pay button

The Amazon Pay button appears in several places in the shop:

• on the shopping cart page,

• in the 1st step of the default One Page Checkout,

• in the sidebar cart widget.

images/1.7.2/order_step_1.png

You can also place the Amazon Pay button in any place you like by including following statement in the template file:

<div data-lpa-role="pay-button"></div>

Pressing the Amazon Pay button launches the Amazon Payments authentication window, where the customer is asked
for his Amazon account e-mail address and password.

images/1.7.2/order_step_2.png

After a successful login the customer is redirected to the Amazon Pay checkout page in your shop.
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7.2 Placing an order

The Amazon Pay checkout form consists of 4 steps arranged within a single page (unlike OpenMage default checkout,
which uses accordion for showing and hiding particular steps of the checkout). These steps are: shipping address
(provided by Amazon Pay), payment method (provided by Amazon Pay), shipping method and order review (handled
by default OpenMage checkout templates). All fields in the form (shipping address, payment method and shipping
method) are pre-filled, which means that in very basic scenario customer can finish the checkout with just one click.
Unfortunately, pre-filling doesn’t apply to the terms and conditions checkbox (if used at all) and can raise the number of
required clicks, which, however, doesn’t affect the easiness and user-friendliness of the Amazon Pay payment method.

images/1.7.2/order_step_3.png

Note: The value selected in each checkout step is saved in a separate AJAX call. When the checkout form shows up
for the first time, depending on the internet connection speed and the web-server’s response time, it may take up to few
seconds until Place order button gets active and can be clicked by the customer.

After selecting the desired shipping address, payment method, shipping method and pressing Place order button (pre-
ceded by accepting terms and conditions if needed), the customer is redirected to the success page. Amazon Pay uses
the default OpenMage success page, which means there’s no need to add any tracking scripts or additional page layout
elements that you use in default OpenMage checkout and want also use in Amazon checkout, all features implemented
additionally on the OpenMage success page shall also appear on Amazon checkout success page.

images/1.7.2/order_step_4.png

The created order will be transferred to Amazon and will appear in your OpenMage admin in Pending (by default) or
Processing (if you are using synchronous authorization) state.

Note: You may notice in the OpenMage admin that the billing address may be incorrect at this point (as mentioned
in the introduction to this chapter). That’s true if the billing differs from the shipping data. The billing address will be
updated as soon as authorization is confirmed by Amazon Pay. Keep also in mind that the billing address is available
only for the sellers that provided a valid VAT number in Amazon Seller Central.
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7.3 Multicurrency support

Amazon Pay extension supports multicurrency payments on the website level. Website is the top level organizational
unit in OpenMage, it may share customer accounts, shipping and payment methods. To offer multicurrency support that
is provided by Amazon Pay service in your OpenMage shop, you have to create a separate website for each currency
you plan to offer in your shop, with the selected currency set as a base currency in OpenMage settings.

images/multicurrency_websites.png

By default the base currency is set globally in OpenMage, to make it available on the website level, please go to System
→ Configuration → Catalog → Catalog → Price → Catalog Price Scope and set its value to Website.

images/catalog_price_scope.png

Next go to System → Configuration → General → Currency Setup → Currency Options → Base Currency and set its
value to the selected currency for each of the websites you created previously to offer multicurrency support for your
customers. The website configuration scope can be changed by selecting appropriate entry in the Current Configuration
Scope dropdown list in the top right corner of the configuration page.

images/website_currency_setup.png

Note: Please note, that multicurrency support in the extension doesn’t use Display Currency setting, which may be
set on the store view level. Display currency is used just for the storefront presentation purposes and doesn’t play any
role in further order post-processing, because all transactions are processed using base currency. Such a behavior is
implemented in OpenMage core classes and Amazon Pay extension do not break this rule.

7.4 Payment authorization

An authorization can be requested after the order data is successfully transferred to Amazon. Depending on the value
you’ve selected for Payment Action option it can be processed in several ways. For Authorize and Authorize & capture
actions it will be requested automatically as soon as order is placed in your shop and successfully transferred to Amazon.
The requested authorization will be therefore either confirmed or declined by Amazon either via IPN message or via
data polling, see workflow-synchronizing-order-data to get more details. The order, for which a payment authorization
has been confirmed changes its state to Processing, an order email confirmation is sent to the customer (if not disabled
in the extension settings, see configuration-order-confirmation) and you can start the fulfilment process.
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Warning: Never dispatch ordered items before the authorization is confirmed. Only the confirmed authorization
guarantees that you will be able to capture the order amount (if you capture within 7 days).

7.4.1 Declined authorizations

If the authorization is declined by Amazon Pay due to problem with the payment method selected, your customer
will be informed about this case via e-mail and requested to visit the Amazon Pay web site. The customer can on
this page update the payment method by following the instructions on the web page. The e-mail sent to the customer
can be adjusted according to the customization-email-templates section. After the successful payment method update,
Amazon Pay will notify OpenMage about the new authorization status and payment will get back on the track (via
polling or IPN).

In case the authorization has been declined due to any other reason then problems with the selected payment method,
the notification email will be sent to shop administrator and appropriate action must be undertaken according to the
Amazon Payments Integration Guide.

7.5 Capturing the payment amount

After a successful authorization, you can capture funds against the authorization. Payment Action option in the ex-
tension settings allows to switch between manual and automatic capture mode. For Manual authorization actions the
capture is triggerd by creating manually an invoice for the order in the OpenMage admin. For Authorize & capture
action, the capture is requested automatically as soon as authorization is confirmed by Amazon Pay.

7.5.1 Manual capture

To capture the order amount, you must create an invoice first. To create an invoice, login to the OpenMage admin,
open the order for which you want to capture the amount and click the Invoice button located in the top buttons rows.
Please make sure that the order you want to process has been successfully authorized, which basically means that it is
in Processing state.

images/workflow_screenshot_4.png

After clicking the Invoice button, a new invoice form will appear with most of the crucial data (like products quantity)
already filled in. You can adjust some invoice fields if needed. At this point you can create a shipment as well, by
checking Create Shipment checkbox and adding a tracking number if needed. Before submitting the form, please
make absolutely sure that Amount selectbox is set to Capture online and press Submit Invoice button. A new invoice
and a new shipment (if checked Create Shipment checkbox) will be created for the order and the capture request is sent
to Amazon Pay.

images/workflow_screenshot_5.png
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Warning: To collect the funds that were authorized, you must capture the amount within 30 days of a successful
authorization (two days in Sandbox mode). We strongly recommend that you capture funds within seven days
of authorization to reduce the likelihood of declines (within 7 days the a successful captures is guaranteed). In
case your fulfilment process exceeds 30 days, consider using the Manual authorization as payment action in the
configuration and authorize the payment later in any suitable time (typically in the week before the shipping) before
the shipping.

Note: Partial captures are not supported by the extension at this moment.

The capture status, similar to authorizations, will be updated either via IPN message or via data polling, see workflow-
synchronizing-order-data for more details.

7.5.2 Automatic capture

In this mode the capture is requested automatically after the successful authorization. Also the invoice that covers all
ordered items is created automatically. Post-request processing (capture status synchronization) is carried the same
way as in capture invoked manually from OpenMage backend.

7.6 Refunding order items

The order, which payment has been captured for, can be refunded either fully or partially. Refunds are made against the
invoices and thus having a paid invoice assigned to the order is a necessary condition that has to be met to refund any
order item. Refunds in OpenMage are recorded as credit memos, so for requesting a refund with Amazon Payments
you should create a credit memo first. To create a credit memo login to the OpenMage admin, open the order you want
refund, click Invoices tab on the right, select an invoice you want to refund and click on it.

images/workflow_screenshot_6.png

A preview of the selected invoice will appear. Make sure that you are on the single invoice preview page and click the
Credit Memo button.

images/workflow_screenshot_7.png

A new credit memo form will appear with most of the crucial data (like products quantity to be refunded) already filled
in. If you want to refund the invoice partially (i.e. only a part of the invoiced items) adjust the product quantities to be
refunded (set 0 for items that shall not be refunded) and click Update Qty’s button to update refund totals. You can also
set the refunded items back to stock by checking Return to Stock checkbox. Next choose if you want to refund shipping
costs or apply any refunds adjustment and fill in the appropriate fields. Next before submitting the credit memo form,
double check that you have Refund button available and click it. A credit memo will be created and a refund will be
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requested with Amazon Payments. Its status will be updated either via IPN or data polling, depending on the update
method selected in the extension settings.

images/workflow_screenshot_8.png

Warning: For the successful refund (recorded in OpenMage and requested (!) with Amazon Pay) always use
Refund button available on the new credit memo form invoked from the single invoice preview page. If you click
Credit Memo button directly on the order page you will be redirected to the new credit memo form with Refund
offline button only, which admittedly will record credit memo in OpenMage, but surely won’t call refund request at
Amazon Payments gateway. If in any case you will get a credit memo with Refund offline button only then surely
something had to go wrong and you should stop the refund process immediately and start it from the beginning
following the above guideline.

7.7 Cancelling an order

For a variety of reasons it sometimes becomes necessary to cancel an order. To cancel an order and notify Amazon
Pay about the payment cancellation:

• Please make sure the amount of the order you want to cancel hasn’t been captured yet,

• Go to Sales → Orders and select the order that you would like to cancel by clicking the Edit button on its
respective row,

• Click Cancel in order page to remove this order.

images/workflow_screenshot_9.png
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CHAPTER

EIGHT

FREQUENTLY ASKED QUESTIONS

Is Amazon Pay extension compatible with Magento 1.x?

Amazon Pay extension is implemented for and tested against OpenMage platform, which is a community-driven suc-
cessor of Magento 1.x, thus, it is very likely that this extension works properly on Magento 1.x as well. Please note that
the official support for Magento 1.x has been dropped, so the extension may be used on Magento 1.x on the merchant’s
sole risk and no support will be provided in case of platform incompatibilities.
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CHAPTER

NINE

TROUBLESHOOTING

9.1 Installing the extension on Magento lower than 1.9.4.0

Amazon Pay extension doesn’t work out of the box with Magento lower than 1.9.4.0 because of the unsupported version
of phpseclib that comes with those Magento versions. However, it is possible to upgrade phpseclib and start using
Amazon Pay extension. To do so, please follow the steps:

1. Identify your Magento version (it’s visible in the footer in Magento admin panel).

2. Check which security patches you have installed in your Magento shop by running the following command in
the root directory of your Magento installation:

cat app/etc/applied.patches.list

3. Go to Magento 1.x Patches page, find your Magento version and compare the patches which are installed in your
Magento shop with the ones required for your version.

4. Install all missing required patches, next download and install PHP 7 compatibility patch.

5. Now your Magento is ready to use Amazon Pay extension. Go to Installation section and install the extension.
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